Home Forums Bug Reports SwithMail Bug Reports Use of ampersand in Swithmail

Viewing 4 reply threads
  • Author
    Posts
    • #170 Score: 0
      Gil Fleming
      Participant

      We are linking Swithmail to our database of suppliers and customers. We generate an xml file, then call Swithmail to use that xml file. The subject line contains the supplier or customer name. If the name contains an ampersand (Jim Brown & Sons Ltd), the email is not sent. When we try to load the xml file via the GUI, the ampersand position is highlighted as a load error. We can modify our customer details to, say Jim Brown + Sons, but it looks a bit odd. Any ideas or workarounds?

    • #179 Score: 0
      tbare
      Keymaster
      1 pt

      Hey, Gil –

      Sorry for the late reply on this. I wasn’t getting email alerts on new posts for a bit. Are you still having this issue?

    • #181 Score: 0
      Gil Fleming
      Participant

      It’s ok, we sorted it.

      We have to use & whenever we have an ampersand in customer name.This involves detecting the & and then substituting it with & . All works fine now.

      Gil

    • #184 Score: 0
      Gil Fleming
      Participant

      The previous post interfered with my typing.
      Looks like the forum actually strips out stuff in the same way that swithmail does!

      To get an ampersand to show, we have to type an ampersand followed by the letters amp followed by a semi colon (all as a single word)

      Gil

    • #187 Score: 0
      tbare
      Keymaster
      1 pt

      Yeah – that’s the HTML code for ampersand — in the forum, yuo could have used the “code” tag:
      & and it would stay. In SwithMail, if you have the HTML flag set, there are characters that need to be in html format to be retained (& > & amp; being the main one). 🙂

      Regardless, glad you got it sorted! 🙂

      Edit – wow – even in code tags it broke it. Guess I need to check that out! :-/

      • This reply was modified 2 years, 4 months ago by tbare.
      • This reply was modified 2 years, 4 months ago by tbare.
      • This reply was modified 2 years, 4 months ago by tbare.
      • This reply was modified 2 years, 4 months ago by tbare.
Viewing 4 reply threads
  • You must be logged in to reply to this topic.